Open Business Intelligence

La red del Business Intelligence

Hola.

Estoy intentando configurar un datasource que se conecte a una base de datos Oracle, pero no consigo dar con la tecla correcta.

He partido de un .WAR de ejemplo de Mondrian, lo he desplegado bajo un servidor JBoss y he modificado una serie de archivos con la finalidad de poder utilizar mi propio Datasource.

El caso es que no consigo configurar correctamente este datasource, ya que, haga lo que haga, siempre me aparece el mismo mensaje de error: "Datasource java:comp/env/jdbc/DataSourceBusquedas is not configured properly."

Los archivos modificados son:

 

'/WEB-INF/datasources.xml'

     <?xml version="1.0"?>
      <DataSources>
          <DataSource>
            <DataSourceName>Provider=Mondrian;DataSource=DataSourceBusquedas;</DataSourceName>
              <DataSourceDescription>Dbusquedas</DataSourceDescription>
              <URL>http://localhost:80/Mondrian/xmla</URL>
             <DataSourceInfo>Provider=mondrian;DynamicSchemaProcessor=mondrian.spi.impl.FilterDynamicSchemaProcessor;UseContentChecksum=true;Jdbc=jdbc:oracle:thin:root/root@192.168.1.4:1521:BBDD;Catalog=/WEB-INF/queries/Busquedas.xml;</DataSourceInfo>
              <ProviderName>Mondrian</ProviderName>
              <ProviderType>MDP</ProviderType>
              <AuthenticationMode>Unauthenticated</AuthenticationMode>
              <Catalogs>
                  <Catalog name="Busquedas">
                      <Definition>/WEB-INF/queries/Busquedas.xml</Definition>
                  </Catalog>
              </Catalogs>
          </DataSource>
      </DataSources>DataSources>

 

'/WEB-INF/queries/Busquedas.jsp'

      <jp:mondrianQuery id="query01" dataSource="DataSourceBusquedas" catalogUri="/WEB-INF/queries/Busquedas.xml">
      ...
      </jp:mondrianQuery>


A pesar de probar todas las combinaciones de configuración en ambos archivos, siempre me aparece el mismo mensaje de error: "Datasource java:comp/env/jdbc/DataSourceBusquedas is not configured properly."

Decidí eliminar eliminar físicamente de mi proyecto el archivo '/WEB-INF/datasources.xml' para ver qué pasaba, y curiosamente me volvió a aparecer el mismo mensaje, por lo que empiezo a pensar que realmente el problema no está en la estructura del archivo 'datasources.xml' (ya que el error es el mismo, exista éste o no), si no que el error puede estar en que no me encuentra nunca este archivo donde defino mi datasuorce.

¿Alguna idea de qué puntos tengo que revisar para asegurarme de que me esté encontrado mi archivo de datasources y que esté bien configurado?

Gracias.

Etiquetas: configuración, configured, datasource, not, oracle, properly

Visitas: 437

Responde a esto

Distintivo

Cargando…

© 2022   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio